brcm2708: split sdcard.img.gz into a sysupgrade and factory image
[openwrt/openwrt.git] / target / linux / brcm2708 / image / Makefile
index 53716e0d773943945343364c9550747df4d08f16..aedea9445162ac46a94ec080be62c22cb5d32897 100644 (file)
@@ -1,80 +1,88 @@
 # 
 # Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016-2017 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
-include $(INCLUDE_DIR)/host.mk
 
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
-### Image scripts ###
-define Build/build-dtb
-       $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $@.dtb $(DTS_DIR)/$(DEVICE_DTS).dts
+define Build/Compile
+       $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
 endef
 
-define Build/gen-cfg
-       cat config.txt > $@.config
-       echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
+### Image scripts ###
+define Build/kernel-img
+       perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
+       mv $@.tmp $@
 endef
 
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
-       mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/COPYING.linux ::
+       mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot $(KDIR)/start.elf ::
        mcopy -i $@.boot $(KDIR)/start_cd.elf ::
        mcopy -i $@.boot $(KDIR)/fixup.dat ::
        mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
        mcopy -i $@.boot cmdline.txt ::
-       mcopy -i $@.boot $@.config ::config.txt
-       mcopy -i $@.boot $(word 1,$^) ::kernel.img
-       mcopy -i $@.boot $@.dtb ::$(DEVICE_DTS).dtb
+       mcopy -i $@.boot config.txt ::
+       mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
+       $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
+       mmd -i $@.boot ::/overlays
+       mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
+       mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
 endef
 
 define Build/sdcard-img
-       ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
+       ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
-  ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
-       gzip -k -f9 $(BIN_DIR)/$(IMG_PREFIX)-sdcard-vfat-$(1).img
-  endif
 endef
 
-### Device macros ###
+### Devices ###
 define Device/Default
-  FILESYSTEMS := ext4
-  PROFILES = Default $$(DEVICE_PROFILE)
-  KERNEL := kernel-bin
-  IMAGES := sdcard.bin
-  IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
-  DEVICE_PROFILE :=
-  DEVICE_NAME :=
-  DEVICE_DTS :=
+  KERNEL := kernel-bin | kernel-img
+  KERNEL_IMG := kernel.img
+  IMAGES := factory.img.gz sysupgrade.img.gz
+  IMAGE/sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
+  IMAGE/factory.img.gz := boot-img | sdcard-img | gzip
 endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
 
-# $(1) = profile
-# $(2) = image name
-# $(3) = dts
-define add_bcm2708
-  define Device/$(2)
-    DEVICE_PROFILE := $(1)
-    DEVICE_NAME := $(2)
-    DEVICE_DTS := $(3)
-  endef
-  TARGET_DEVICES += $(2)
+define Device/rpi
+  DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
+  DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
+  SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 kmod-brcmfmac wpad-mini
 endef
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi
+endif
 
-# Raspberry Pi Model B
-$(eval $(call add_bcm2708,RaspberryPi,rpi-b,bcm2708-rpi-b))
-# Raspberry Pi Model B+
-$(eval $(call add_bcm2708,RaspberryPi,rpi-b-plus,bcm2708-rpi-b-plus))
-# Raspberry Pi 2 Model B
-$(eval $(call add_bcm2708,RaspberryPi2,rpi-2-b,bcm2709-rpi-2-b))
+define Device/rpi-2
+  DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM
+  DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2710-rpi-cm3
+  SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,3-model-b-plus raspberrypi,compute-module-3
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio brcmfmac-board-rpi2 brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
+endef
+ifeq ($(SUBTARGET),bcm2709)
+  TARGET_DEVICES += rpi-2
+endif
+
+define Device/rpi-3
+  KERNEL_IMG := kernel8.img
+  DEVICE_TITLE := Raspberry Pi 3B/3B+
+  DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus
+  SUPPORTED_DEVICES := rpi-3-b rpi-3-b-plus raspberrypi,3-model-b raspberrypi,3-model-b-plus
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 brcmfmac-firmware-43455-sdio brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
+endef
+ifeq ($(SUBTARGET),bcm2710)
+  TARGET_DEVICES += rpi-3
+endif
 
 $(eval $(call BuildImage))