bcm2708: explicitly check for SUBTARGET instead of using the device SUBTARGETS variable
[openwrt/openwrt.git] / target / linux / brcm2708 / image / Makefile
index bfcb522b6469ebbfe2cf4f860559e872e6c9dcff..af45cf47c6fb78021fa12648da551bddf2b5d6d1 100644 (file)
@@ -1,5 +1,6 @@
 # 
 # Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,27 +13,27 @@ FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 ### Image scripts ###
-define Build/gen-cfg
-       cat config.txt > $@.config
-       echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
+define Build/kernel-img
+       perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
+       mv $@.tmp $@
 endef
 
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+       mcopy -i $@.boot $(LINUX_DIR)/COPYING ::COPYING.linux
        mcopy -i $@.boot $(KDIR)/bootcode.bin ::
-       mcopy -i $@.boot $(KDIR)/COPYING.linux ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot $(KDIR)/start.elf ::
        mcopy -i $@.boot $(KDIR)/start_cd.elf ::
        mcopy -i $@.boot $(KDIR)/fixup.dat ::
        mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
        mcopy -i $@.boot cmdline.txt ::
-       mcopy -i $@.boot $@.config ::config.txt
+       mcopy -i $@.boot config.txt ::
        mcopy -i $@.boot $(word 1,$^) ::kernel.img
-       mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
+       $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
        mmd -i $@.boot ::/overlays
-       mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
+       mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
        mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
 endef
 
@@ -42,43 +43,39 @@ define Build/sdcard-img
        $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
 
-### Device macros ###
+### Devices ###
 define Device/Default
   FILESYSTEMS := ext4
-  PROFILES = Default $$(DEVICE_PROFILE)
-  KERNEL := kernel-bin
+  KERNEL := kernel-bin | kernel-img
   IMAGES := sdcard.img
-  IMAGE/sdcard.img := gen-cfg | boot-img | sdcard-img
-  DEVICE_PROFILE :=
+  IMAGE/sdcard.img := boot-img | sdcard-img
   DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
+DEVICE_VARS += DEVICE_DTS
 
-# $(1) = profile
-# $(2) = image name
-# $(3) = dts
-define add_bcm2708
-  define Device/$(2)
-    DEVICE_PROFILE := $(1)
-    DEVICE_DTS := $(3)
-  endef
-  TARGET_DEVICES += $(2)
+define Device/rpi
+  DEVICE_TITLE := Raspberry Pi B/B+/CM
+  DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
 endef
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi
+endif
 
-### BCM2708/BCM2835 ###
+define Device/rpi-2
+  DEVICE_TITLE := Raspberry Pi 2 B
+  DEVICE_DTS := bcm2709-rpi-2-b
+endef
 ifeq ($(SUBTARGET),bcm2708)
-  # Raspberry Pi Model B
-  $(eval $(call add_bcm2708,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
-  # Raspberry Pi Model B+
-  $(eval $(call add_bcm2708,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
-  # Raspberry Pi Compute Module
-  $(eval $(call add_bcm2708,RaspberryPi_CM,rpi-cm,bcm2708-rpi-cm))
+  TARGET_DEVICES += rpi-2
 endif
 
-### BCM2709/BCM2836 ###
-ifeq ($(SUBTARGET),bcm2709)
-  # Raspberry Pi 2 Model B
-  $(eval $(call add_bcm2708,RaspberryPi_2,rpi-2-b,bcm2709-rpi-2-b))
+define Device/rpi-3
+  DEVICE_TITLE := Raspberry Pi 3 B
+  DEVICE_DTS := bcm2710-rpi-3-b
+  DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
+endef
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi-3
 endif
 
 $(eval $(call BuildImage))