bcm2708: explicitly check for SUBTARGET instead of using the device SUBTARGETS variable
[openwrt/openwrt.git] / target / linux / brcm2708 / image / Makefile
index cb5acde48cdae331fdae171ad74fb77ec5ae7c82..af45cf47c6fb78021fa12648da551bddf2b5d6d1 100644 (file)
@@ -1,5 +1,6 @@
 # 
 # Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,30 +12,70 @@ include $(INCLUDE_DIR)/host.mk
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
-define Image/Build/RaspberryPi
-       rm -f $(KDIR)/boot.img
-
-       mkdosfs -C $(KDIR)/boot.img $(FAT32_BLOCKS)
-       # Raspberry Pi has no bootloader, instead the GPU loads and starts the kernel
-       mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/bootcode.bin ::
-       mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/COPYING.linux ::
-       mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/LICENCE.broadcom ::
-       mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/start.elf ::
-       mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/start_cd.elf ::
-       mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/fixup.dat ::
-       mcopy -i $(KDIR)/boot.img $(BUILD_DIR)/brcm2708-gpu-fw-boot/fixup_cd.dat ::
-       mcopy -i $(KDIR)/boot.img cmdline.txt ::
-       mcopy -i $(KDIR)/boot.img config.txt ::
-       mcopy -i $(KDIR)/boot.img $(KDIR)/Image ::kernel.img  # Copy OpenWrt built kernel
-       ./gen_rpi_sdcard_img.sh $(BIN_DIR)/$(IMG_PREFIX)-sdcard-vfat-$(1).img $(KDIR)/boot.img $(KDIR)/root.$(1) \
+### Image scripts ###
+define Build/kernel-img
+       perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
+       mv $@.tmp $@
+endef
+
+define Build/boot-img
+       rm -f $@.boot
+       mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+       mcopy -i $@.boot $(LINUX_DIR)/COPYING ::COPYING.linux
+       mcopy -i $@.boot $(KDIR)/bootcode.bin ::
+       mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
+       mcopy -i $@.boot $(KDIR)/start.elf ::
+       mcopy -i $@.boot $(KDIR)/start_cd.elf ::
+       mcopy -i $@.boot $(KDIR)/fixup.dat ::
+       mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
+       mcopy -i $@.boot cmdline.txt ::
+       mcopy -i $@.boot config.txt ::
+       mcopy -i $@.boot $(word 1,$^) ::kernel.img
+       $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
+       mmd -i $@.boot ::/overlays
+       mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
+       mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
+endef
+
+define Build/sdcard-img
+       ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+       $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
 
-define Image/Build
-       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
-       $(CP) $(KDIR)/Image $(BIN_DIR)/$(IMG_PREFIX)-Image
+### Devices ###
+define Device/Default
+  FILESYSTEMS := ext4
+  KERNEL := kernel-bin | kernel-img
+  IMAGES := sdcard.img
+  IMAGE/sdcard.img := boot-img | sdcard-img
+  DEVICE_DTS :=
+endef
+DEVICE_VARS += DEVICE_DTS
+
+define Device/rpi
+  DEVICE_TITLE := Raspberry Pi B/B+/CM
+  DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
+endef
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi
+endif
+
+define Device/rpi-2
+  DEVICE_TITLE := Raspberry Pi 2 B
+  DEVICE_DTS := bcm2709-rpi-2-b
+endef
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi-2
+endif
 
-       $(call Image/Build/RaspberryPi,$(1))
+define Device/rpi-3
+  DEVICE_TITLE := Raspberry Pi 3 B
+  DEVICE_DTS := bcm2710-rpi-3-b
+  DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
 endef
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi-3
+endif
 
 $(eval $(call BuildImage))