brcm2708: boot-part feature integration
[openwrt/openwrt.git] / target / linux / brcm2708 / image / Makefile
index 80a019270de74e4af0621d5e7856a92df4df7f88..cd00d7f3943709f57a69b90b97a11a068938de4b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 FAT32_BLOCK_SIZE=1024
-FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+FAT32_BLOCKS=$(shell echo $$(($(CONFIG_TARGET_KERNEL_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 define Build/Compile
        $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
@@ -29,8 +29,10 @@ define Build/boot-img
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot $(KDIR)/start.elf ::
        mcopy -i $@.boot $(KDIR)/start_cd.elf ::
+       mcopy -i $@.boot $(KDIR)/start_x.elf ::
        mcopy -i $@.boot $(KDIR)/fixup.dat ::
        mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
+       mcopy -i $@.boot $(KDIR)/fixup_x.dat ::
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot config.txt ::
        mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
@@ -42,22 +44,27 @@ endef
 
 define Build/sdcard-img
        ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
-               $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 endef
 
 ### Devices ###
 define Device/Default
   KERNEL := kernel-bin | kernel-img
   KERNEL_IMG := kernel.img
-  IMAGES := sdcard.img.gz
-  IMAGE/sdcard.img.gz := boot-img | sdcard-img | gzip | append-metadata
+  IMAGES := factory.img.gz sysupgrade.img.gz
+  IMAGE/sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
+  IMAGE/factory.img.gz := boot-img | sdcard-img | gzip
 endef
 
 define Device/rpi
   DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
   DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
-  SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
-  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 kmod-brcmfmac wpad-mini
+  SUPPORTED_DEVICES := \
+       rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w \
+       raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,model-b-rev2 \
+       raspberrypi,compute-module raspberrypi,compute-module-1 \
+       raspberrypi,model-zero raspberrypi,model-zero-w
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 kmod-brcmfmac wpad-basic
 endef
 ifeq ($(SUBTARGET),bcm2708)
   TARGET_DEVICES += rpi
@@ -66,8 +73,12 @@ endif
 define Device/rpi-2
   DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM
   DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2710-rpi-cm3
-  SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,3-model-b-plus raspberrypi,compute-module-3
-  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio brcmfmac-board-rpi2 brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
+  SUPPORTED_DEVICES := \
+       rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm \
+       raspberrypi,2-model-b \
+       raspberrypi,3-model-b raspberrypi,3-model-b-plus \
+       raspberrypi,3-compute-module raspberrypi,compute-module-3
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio brcmfmac-board-rpi2 brcmfmac-board-rpi3 kmod-brcmfmac wpad-basic
 endef
 ifeq ($(SUBTARGET),bcm2709)
   TARGET_DEVICES += rpi-2
@@ -77,8 +88,11 @@ define Device/rpi-3
   KERNEL_IMG := kernel8.img
   DEVICE_TITLE := Raspberry Pi 3B/3B+
   DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus
-  SUPPORTED_DEVICES := rpi-3-b rpi-3-b-plus raspberrypi,3-model-b raspberrypi,3-model-b-plus
-  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 brcmfmac-firmware-43455-sdio brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
+  SUPPORTED_DEVICES := \
+       rpi-3-b rpi-3-b-plus \
+       raspberrypi,3-model-b raspberrypi,3-model-b-plus \
+       raspberrypi,3-compute-module raspberrypi,compute-module-3
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 brcmfmac-firmware-43455-sdio brcmfmac-board-rpi3 kmod-brcmfmac wpad-basic
 endef
 ifeq ($(SUBTARGET),bcm2710)
   TARGET_DEVICES += rpi-3