brcm63xx: switch to linux 4.4
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index c4dfa25a3b02aef7f3e5085a76640651fbb0f6fa..0dba065d0d4c3b0f1faf1344c67e3521283db25e 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +11,13 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
-FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.24
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+FEATURES:=squashfs usb atm pci pcmcia usbgadget
+KERNEL_PATCHVER:=4.4
+MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers