kernel: m25p80: allow fallback from spi_flash_read to regular SPI transfer
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index 1fcbc8174fbb0616eb6700aee150032f05cde506..1aed6b20e5aea159e7c4c903f37f7c09ecef7925 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +11,9 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
-FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.12
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
+FEATURES:=squashfs usb atm pci pcmcia usbgadget
+KERNEL_PATCHVER:=4.9
+MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
@@ -24,4 +21,8 @@ define Target/Description
        (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))