brcm63xx: fix invalid Asmax AR 1004g DTS reference
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index 36bf845ec4fca40aa00999b6769ef207f72fe0da..84e9a8d44e35ef19d6f283e864e8b8031d081c3d 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,12 +12,8 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia usbgadget
-LINUX_VERSION:=3.14.14
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
+KERNEL_PATCHVER:=4.4
+MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
@@ -24,4 +21,8 @@ define Target/Description
        (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))