brcm63xx: fix invalid Asmax AR 1004g DTS reference
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index 49573ad562fb888cc6648866a165c21357f8f201..84e9a8d44e35ef19d6f283e864e8b8031d081c3d 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +10,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.35.8
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += wpad-mini kmod-switch gpioctl
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia usbgadget
+KERNEL_PATCHVER:=4.4
+MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
@@ -22,4 +21,8 @@ define Target/Description
        (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))