brcm63xx: switch to 4.1
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index 200040b0bcc51376bafa029a1314ce653531fe0b..f96897cfd146ec639eb9ff58a5c0bfc4a01b880e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.27.26
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia usbgadget
+KERNEL_PATCHVER:=4.1
+MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-switch gpioctl
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
-       currently supports BCM6348 and BCM6358 based devices.
+       currently supports BCM6338, BCM6348 and BCM6358 based devices.
        (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef