brcm63xx: add support for Pirelli/ADB P.DG AV4202N
[openwrt/openwrt.git] / target / linux / brcm63xx / image / bcm63xx.mk
index ce03f7b700290437ed2e9be54a023bfe441a5502..f38147eb365b321e35a8406eac26fc52899cff9e 100644 (file)
@@ -200,6 +200,18 @@ define Device/A4001N1
 endef
 TARGET_DEVICES += A4001N1
 
 endef
 TARGET_DEVICES += A4001N1
 
+define Device/AV4202N
+  $(Device/bcm63xx)
+  IMAGE_OFFSET := 0x20000
+  DEVICE_TITLE := ADB P.DG AV4202N
+  DEVICE_DTS := av4202n
+  CFE_BOARD_ID := 96368_Swiss_S1
+  CFE_CHIP_ID := 6368
+  DEVICE_PACKAGES := \
+    $(USB2_PACKAGES) $(B43_PACKAGES)
+endef
+TARGET_DEVICES += AV4202N
+
 ### Alcatel ###
 define Device/RG100A
   $(Device/bcm63xx)
 ### Alcatel ###
 define Device/RG100A
   $(Device/bcm63xx)