gemini: cleanup kernel config
[openwrt/openwrt.git] / target / linux / gemini / Makefile
index 0ec830b7dd70363bd7e1496516f3138f457a1c56..4b46bc23a1ab31141e9c713ee034141b5705b247 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
+FEATURES:=squashfs pci rtc usb dt gpio display
+CPU_TYPE:=fa526
+MAINTAINER:=Roman Yeryomin <roman@advem.lv>
 
-LINUX_VERSION:=2.6.32.14
+KERNEL_PATCHVER:=4.14
+
+define Target/Description
+       Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-led-trig-heartbeat \
+       kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))