gemini: Fix kmod-led-trig-heartbeat typo
[openwrt/openwrt.git] / target / linux / gemini / Makefile
index 09f4c4352ab0342d38b7db2fd042cb7f501ca1b3..7c573c7c6d09fd8bd4214e2f672c36007e7b80bd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,24 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-SUBTARGETS:=raidsonic wiligear
-FEATURES:=squashfs pci rtc
+FEATURES:=squashfs pci rtc usb dt gpio display
 CPU_TYPE:=fa526
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+MAINTAINER:=Roman Yeryomin <roman@advem.lv>
 
-KERNEL_PATCHVER:=3.10
+KERNEL_PATCHVER:=4.14
 
-KERNELNAME:=zImage
+define Target/Description
+       Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-usb-core kmod-usb-fotg210 \
+       kmod-usb-ledtrig-usbport \
+       kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))