mpc85xx: fix address config for ws-ap3825i
[openwrt/openwrt.git] / target / linux / gemini / Makefile
index 7eb751ec703c553963c1a6b06c27b1a93ba91bc9..b7f1962c9a59047e981ca6eebbaffcd6ebe99df3 100644 (file)
@@ -1,22 +1,30 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2009-2018 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs pci
+FEATURES:=squashfs pci rtc usb dt gpio display ext4 rootfs-part boot-part
 CPU_TYPE:=fa526
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=3.10
+KERNEL_PATCHVER:=6.1
 
-KERNELNAME:=zImage
+define Target/Description
+       Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-usb-fotg210 \
+       kmod-usb-ledtrig-usbport \
+       kmod-leds-gpio \
+       kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))