uclient: update to Git HEAD (2024-04-19)
[openwrt/openwrt.git] / target / linux / gemini / Makefile
index d0e7bb9cc35f40a38f145bb0a2541d6f5c4046be..b7f1962c9a59047e981ca6eebbaffcd6ebe99df3 100644 (file)
@@ -1,19 +1,30 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2009-2018 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
+FEATURES:=squashfs pci rtc usb dt gpio display ext4 rootfs-part boot-part
+CPU_TYPE:=fa526
+SUBTARGETS:=generic
 
-LINUX_VERSION:=2.6.30.10
+KERNEL_PATCHVER:=6.1
+
+define Target/Description
+       Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-usb-fotg210 \
+       kmod-usb-ledtrig-usbport \
+       kmod-leds-gpio \
+       kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))