uclient: update to Git HEAD (2024-04-19)
[openwrt/openwrt.git] / target / linux / gemini / Makefile
index f02e4b179f7ff0d609bf378b4928e9d2812e93ad..b7f1962c9a59047e981ca6eebbaffcd6ebe99df3 100644 (file)
@@ -1,23 +1,30 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2009-2018 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-SUBTARGETS:=raidsonic wiligear
-FEATURES:=squashfs pci rtc
+FEATURES:=squashfs pci rtc usb dt gpio display ext4 rootfs-part boot-part
 CPU_TYPE:=fa526
-MAINTAINER:=Roman Yeryomin <roman@advem.lv>
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=6.1
 
-KERNELNAME:=zImage
+define Target/Description
+       Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-usb-fotg210 \
+       kmod-usb-ledtrig-usbport \
+       kmod-leds-gpio \
+       kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))