gemini: dlink-dir-685: fix rt2800-pci package name
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index 36ab53d0f21725ba4a5d292e2e1f449e0de80c64..d0180e297acf72cfec9bd15d73af49099327d92e 100644 (file)
@@ -113,7 +113,7 @@ define Device/dlink_dir-685
        DEVICE_DTS := gemini-dlink-dir-685
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
                        kmod-switch-rtl8366rb swconfig \
-                       rt2800-pci
+                       kmod-rt2800-pci
        IMAGES := factory.bin
        IMAGE/factory.bin := dir685-images
 endef
@@ -130,7 +130,8 @@ TARGET_DEVICES += dlink_dns-313
 
 define Device/itian-raidsonic
        IMAGES := factory.bin
-       IMAGE/factory.bin := append-rootfs | pad-to 6144k | nas4220b-sq201-images $(1)
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
+               nas4220b-sq201-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
 
@@ -138,7 +139,7 @@ define Device/itian_sq201
        $(Device/itian-raidsonic)
        DEVICE_TITLE := ITian Square One SQ201
        DEVICE_DTS := gemini-sq201
-       DEVICE_PACKAGES += rt61-pci usb2-pci
+       DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
 endef
 TARGET_DEVICES += itian_sq201