gemini: dlink-dir-685: fix rt2800-pci package name
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index 3f4dc62677bc483f72bba55c95aa9e73be49d269..d0180e297acf72cfec9bd15d73af49099327d92e 100644 (file)
@@ -45,6 +45,17 @@ define Build/dns313-images
        rm -rf $@.tmp
 endef
 
+define Build/wiligear-image
+       $(STAGING_DIR_HOST)/bin/mkfwimage2 \
+               -m GEOS -f 0x30000000 -z \
+               -v $(1).v5.00.SL3512.OpenWrt.00000.000000.000000 \
+               -p Kernel:0x020000:0x100000:0:0:$(IMAGE_KERNEL) \
+               -p Ramdisk:0x120000:0x500000:0:0:$@ \
+               -o $@.new
+
+       mv $@.new $@
+endef
+
 # Create the special NAS4220B and Itian Square One SQ201 image
 # format with the squashfs and overlay inside the "rd.gz" file.
 # We pad it out to 6144K which is the size of the initramfs partition.
@@ -60,6 +71,8 @@ define Build/nas4220b-sq201-images
        cp $(IMAGE_KERNEL) $@.tmp/zImage
        cp ./ImageInfo-$(1) $@.tmp/ImageInfo
 
+       sed -i -e "s/DATESTR/`date +%Y%m%d $(if $(SOURCE_DATE_EPOCH),--date "@$(SOURCE_DATE_EPOCH)")`/g" $@.tmp/ImageInfo
+
        (cd $@.tmp; tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ * \
                $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)"))
 
@@ -100,7 +113,7 @@ define Device/dlink_dir-685
        DEVICE_DTS := gemini-dlink-dir-685
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
                        kmod-switch-rtl8366rb swconfig \
-                       rt2800-pci
+                       kmod-rt2800-pci
        IMAGES := factory.bin
        IMAGE/factory.bin := dir685-images
 endef
@@ -115,46 +128,50 @@ define Device/dlink_dns-313
 endef
 TARGET_DEVICES += dlink_dns-313
 
-define Device/nas4220b-sq201
+define Device/itian-raidsonic
        IMAGES := factory.bin
-       IMAGE/factory.bin := append-rootfs | pad-to 6144k | nas4220b-sq201-images $(1)
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-endef
-
-define Device/raidsonic_ib-4220-b
-       $(Device/nas4220b-sq201)
-       DEVICE_TITLE := Raidsonic NAS IB-4220-B
-       DEVICE_DTS := gemini-nas4220b
-endef
-TARGET_DEVICES += raidsonic_ib-4220-b
-
-define Device/teltonika_rut1xx
-       DEVICE_TITLE := Teltonika RUT1xx
-       DEVICE_DTS := gemini-rut1xx
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
+               nas4220b-sq201-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
-TARGET_DEVICES += teltonika_rut1xx
 
 define Device/itian_sq201
-       $(Device/nas4220b-sq201)
+       $(Device/itian-raidsonic)
        DEVICE_TITLE := ITian Square One SQ201
        DEVICE_DTS := gemini-sq201
-       DEVICE_PACKAGES += rt61-pci usb2-pci
+       DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
 endef
 TARGET_DEVICES += itian_sq201
 
+define Device/raidsonic_ib-4220-b
+       $(Device/itian-raidsonic)
+       DEVICE_TITLE := Raidsonic NAS IB-4220-B
+       DEVICE_DTS := gemini-nas4220b
+endef
+TARGET_DEVICES += raidsonic_ib-4220-b
+
+# The wiliboard images need some changes to be functional and buildable.
+#
+# The dts would need to use the ecoscentric,redboot-fis-partitions partition
+# parser to get the correct partition offsets and size.
+#
+# The mkfwimage2 call need to be adjusted to reflect the real size of kernel
+# and rootfs. It is expected that the OEM firmware adjusts the on flash
+# partition table with the values defined in the image header.
 define Device/wiliboard_wbd111
        DEVICE_TITLE := Wiliboard WBD-111
        DEVICE_DTS := gemini-wbd111
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WILIBOARD"
 endef
-TARGET_DEVICES += wiliboard_wbd111
 
 define Device/wiliboard_wbd222
        DEVICE_TITLE := Wiliboard WBD-222
        DEVICE_DTS := gemini-wbd222
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WBD222"
 endef
-TARGET_DEVICES += wiliboard_wbd222
 
 $(eval $(call BuildImage))