gemini: dlink-dir-685: fix rt2800-pci package name
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index 908045a2de3c5ed674754d8335d50e8147141efa..d0180e297acf72cfec9bd15d73af49099327d92e 100644 (file)
@@ -7,40 +7,76 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-# Build the special D-Link DNS-313 header generator tool
-# needed to generate the hard disk boot images then
-# build D-Link DNS-313 images using the special header tool.
+# Cook a "WRGG" image, this board is apparently one in the D-Link
+# WRGG family and uses the exact same firmware format as other
+# D-Link devices.
+define Build/dir685-images
+       mkwrggimg -i $(IMAGE_KERNEL) \
+       -o $@.new \
+       -d /dev/mtdblock/1 \
+       -s wrgns01_dlwbr_dir685RBWW \
+       -v 'N/A' \
+       -m dir685 \
+       -B 96bb
+
+       mv $@.new $@
+endef
+
+# Build D-Link DNS-313 images using the special header tool.
 # rootfs.tgz and rd.tgz contains nothing, we only need them
 # to satisfy the boot loader on the device. The zImage is
 # the only real content.
 define Build/dns313-images
-       if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
-       mkdir -p $(BIN_DIR)/.boot
-       echo "dummy" > $(BIN_DIR)/.boot/dummyfile
-       dns313-header $(BIN_DIR)/.boot/dummyfile \
-               $(BIN_DIR)/.boot/rootfs.tgz
-       dns313-header $(BIN_DIR)/.boot/dummyfile \
-               $(BIN_DIR)/.boot/rd.gz
+       mkdir -p $@.tmp/.boot
+
+       echo "dummy" > $@.tmp/dummyfile
+
+       dns313-header $@.tmp/dummyfile \
+               $@.tmp/.boot/rootfs.tgz
+       dns313-header $@.tmp/dummyfile \
+               $@.tmp/.boot/rd.gz
        dns313-header $(IMAGE_KERNEL) \
-               $(BIN_DIR)/.boot/zImage
-       rm -f $(BIN_DIR)/.boot/dummyfile
-       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-dns313-bootpart.tar.gz .boot)
-       if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
+               $@.tmp/.boot/zImage
+
+       tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ \
+               -C $@.tmp .boot \
+               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)")
+
+       rm -rf $@.tmp
 endef
 
-# Create the special NAS4220B image format with the squashfs
-# split across two "partitions" named rd.gz and hddapp.tgz but
-# essentially just being used by OpenWRT as one big partition
-define Build/nas4220b-images
-       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/rd.gz bs=6144k conv=sync
-       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
-       cp $(IMAGE_KERNEL) $(BIN_DIR)/zImage
-       cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
-       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220b.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
-       mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-rd.gz
-       mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-hddapp.tgz
-       mv $(BIN_DIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-zImage
-       rm -f $(BIN_DIR)/ImageInfo
+define Build/wiligear-image
+       $(STAGING_DIR_HOST)/bin/mkfwimage2 \
+               -m GEOS -f 0x30000000 -z \
+               -v $(1).v5.00.SL3512.OpenWrt.00000.000000.000000 \
+               -p Kernel:0x020000:0x100000:0:0:$(IMAGE_KERNEL) \
+               -p Ramdisk:0x120000:0x500000:0:0:$@ \
+               -o $@.new
+
+       mv $@.new $@
+endef
+
+# Create the special NAS4220B and Itian Square One SQ201 image
+# format with the squashfs and overlay inside the "rd.gz" file.
+# We pad it out to 6144K which is the size of the initramfs partition.
+#
+# The "application" partition is just blank. You can put anything
+# there when using OpenWRT. We just use that to create the
+# "sysupgrade" firmware image.
+define Build/nas4220b-sq201-images
+       mkdir -p $@.tmp
+
+       mv $@ $@.tmp/rd.gz
+       dd if=/dev/zero of=$@.tmp/hddapp.tgz bs=6144k count=1
+       cp $(IMAGE_KERNEL) $@.tmp/zImage
+       cp ./ImageInfo-$(1) $@.tmp/ImageInfo
+
+       sed -i -e "s/DATESTR/`date +%Y%m%d $(if $(SOURCE_DATE_EPOCH),--date "@$(SOURCE_DATE_EPOCH)")`/g" $@.tmp/ImageInfo
+
+       (cd $@.tmp; tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ * \
+               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)"))
+
+       rm -rf $@.tmp
 endef
 
 # WBD-111 and WBD-222:
@@ -56,75 +92,86 @@ endef
 
 # All DTB files are prefixed with "gemini-"
 define Device/Default
-       DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
+       PROFILES := Default
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
-       FILESYSTEMS := squashfs
-       IMAGE_NAME := $$(IMAGE_PREFIX)-$$(1).$$(2)
        BLOCKSIZE := 128k
-       PAGESIZE := 2048
 endef
 
 # A reasonable set of default packages handling the NAS type
 # of devices out of the box (former NAS42x0 IcyBox defaults)
 GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
                kmod-md-raid0 kmod-md-raid1 kmod-md-raid10 kmod-md-raid456 \
-               kmod-fs-btrfs kmod-fs-cifs kmod-fs-ext4 kmod-fs-nfs \
+               kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
                kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
                kmod-nls-utf8 kmod-usb-storage-extras \
                samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
 
-DIR685_CMDLINE:=-console=ttyS0,19200n8 root=/dev/sda1 rw rootwait
-define Device/dlink-dir-685
+define Device/dlink_dir-685
        DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
-       CMDLINE := $(DIR685_CMDLINE)
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+       DEVICE_DTS := gemini-dlink-dir-685
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
+                       kmod-switch-rtl8366rb swconfig \
+                       kmod-rt2800-pci
+       IMAGES := factory.bin
+       IMAGE/factory.bin := dir685-images
 endef
-TARGET_DEVICES += dlink-dir-685
+TARGET_DEVICES += dlink_dir-685
 
-DNS313_CMDLINE:=-console=ttyS0,19200n8 root=/dev/sda4 rw rootwait
-define Device/dlink-dns-313
+define Device/dlink_dns-313
        DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
-       CMDLINE := $(DNS313_CMDLINE)
+       DEVICE_DTS := gemini-dlink-dns-313
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-       IMAGES += dns313-image
-       IMAGE/dns313-image := dns313-images
+       IMAGES := factory.bin
+       IMAGE/factory.bin := dns313-images
 endef
-TARGET_DEVICES += dlink-dns-313
+TARGET_DEVICES += dlink_dns-313
 
-define Device/nas4220b
-       DEVICE_TITLE := Raidsonic NAS IB-4220-B
-       IMAGES += nas4220b-image
-       IMAGE/nas4220b-image := nas4220b-images
+define Device/itian-raidsonic
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
+               nas4220b-sq201-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
-TARGET_DEVICES += nas4220b
 
-define Device/rut1xx
-       DEVICE_TITLE := Teltonika RUT1xx
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+define Device/itian_sq201
+       $(Device/itian-raidsonic)
+       DEVICE_TITLE := ITian Square One SQ201
+       DEVICE_DTS := gemini-sq201
+       DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
 endef
-TARGET_DEVICES += rut1xx
+TARGET_DEVICES += itian_sq201
 
-SQ201_CMDLINE:=-console=ttyS0,115200n8
-define Device/sq201
-       DEVICE_TITLE := ITian Square One SQ201
-       CMDLINE := $(SQ201_CMDLINE)
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci-firmware
+define Device/raidsonic_ib-4220-b
+       $(Device/itian-raidsonic)
+       DEVICE_TITLE := Raidsonic NAS IB-4220-B
+       DEVICE_DTS := gemini-nas4220b
 endef
-TARGET_DEVICES += sq201
+TARGET_DEVICES += raidsonic_ib-4220-b
 
-define Device/wbd111
+# The wiliboard images need some changes to be functional and buildable.
+#
+# The dts would need to use the ecoscentric,redboot-fis-partitions partition
+# parser to get the correct partition offsets and size.
+#
+# The mkfwimage2 call need to be adjusted to reflect the real size of kernel
+# and rootfs. It is expected that the OEM firmware adjusts the on flash
+# partition table with the values defined in the image header.
+define Device/wiliboard_wbd111
        DEVICE_TITLE := Wiliboard WBD-111
+       DEVICE_DTS := gemini-wbd111
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WILIBOARD"
 endef
-TARGET_DEVICES += wbd111
 
-define Device/wbd222
+define Device/wiliboard_wbd222
        DEVICE_TITLE := Wiliboard WBD-222
+       DEVICE_DTS := gemini-wbd222
        KERNEL := kernel-bin | append-dtb | wbd-nops
+       IMAGES := factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | wiligear-image "WILI-S.WBD222"
 endef
-TARGET_DEVICES += wbd222
 
 $(eval $(call BuildImage))