gemini: Support sysupgrade on DIR-685
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index 9dd37ab70292f45641eca1833d70b5e1e26a235e..ddc2fb9a138ce81138dde136a41d9b33337ae4a8 100644 (file)
@@ -115,6 +115,7 @@ define Device/Default
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
        BLOCKSIZE := 128k
+       SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
 # A reasonable set of default packages handling the NAS type
@@ -143,15 +144,17 @@ define Device/dlink_dir-685
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
                        kmod-switch-rtl8366rb swconfig \
                        kmod-rt2800-pci
-       IMAGES := factory.bin
+       IMAGES := factory.bin sysupgrade.bin
        # Pad to 128k erase blocks with 160 bytes WRGG header
        IMAGE/factory.bin := append-kernel | pad-offset 128k 160 | append-rootfs | dir685-pad-rootfs | dir685-image
+       IMAGE/sysupgrade.bin := append-kernel | pad-offset 128k 160 | dir685-image | append-rootfs | dir685-pad-rootfs | append-metadata
 endef
 TARGET_DEVICES += dlink_dir-685
 
 define Device/dlink_dns-313
        DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
        DEVICE_DTS := gemini-dlink-dns-313
+       DEVICE_TYPE := nas
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
        BLOCKSIZE := 1k
        FILESYSTEMS := ext4
@@ -179,6 +182,7 @@ define Device/raidsonic_ib-4220-b
        $(Device/itian-raidsonic)
        DEVICE_TITLE := Raidsonic NAS IB-4220-B
        DEVICE_DTS := gemini-nas4220b
+       DEVICE_TYPE := nas
 endef
 TARGET_DEVICES += raidsonic_ib-4220-b