gemini: Support sysupgrade on DIR-685
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index aca6e11df2206fa0c104874ba8c7528a70ea015a..ddc2fb9a138ce81138dde136a41d9b33337ae4a8 100644 (file)
@@ -10,8 +10,8 @@ include $(INCLUDE_DIR)/image.mk
 # Cook a "WRGG" image, this board is apparently one in the D-Link
 # WRGG family and uses the exact same firmware format as other
 # D-Link devices.
-define Build/dir685-images
-       mkwrggimg -i $(IMAGE_KERNEL) \
+define Build/dir685-image
+       mkwrggimg -i $@ \
        -o $@.new \
        -d /dev/mtdblock/1 \
        -s wrgns01_dlwbr_dir685RBWW \
@@ -22,12 +22,19 @@ define Build/dir685-images
        mv $@.new $@
 endef
 
+# Padding added after the rootfs to an even 128k boundary
+# as this is 128k eraseblocks flash.
+define Build/dir685-pad-rootfs
+       $(STAGING_DIR_HOST)/bin/padjffs2 $(IMAGE_ROOTFS) -c 128 >>$@
+endef
+
 # Build D-Link DNS-313 images using the special header tool.
 # rootfs.tgz and rd.tgz contains nothing, we only need them
 # to satisfy the boot loader on the device. The zImage is
 # the only real content.
 define Build/dns313-images
        mkdir -p $@.tmp/.boot
+       chmod 755 $@.tmp/.boot
 
        echo "dummy" > $@.tmp/dummyfile
 
@@ -38,9 +45,20 @@ define Build/dns313-images
        dns313-header $(IMAGE_KERNEL) \
                $@.tmp/.boot/zImage
 
-       tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ \
-               -C $@.tmp .boot \
-               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)")
+       rm $@.tmp/dummyfile
+
+       genext2fs --block-size $(BLOCKSIZE:%k=%Ki) \
+               --size-in-blocks $$((1024 * $(CONFIG_TARGET_KERNEL_PARTSIZE))) \
+               --squash-uids \
+               --root $@.tmp $@.tmp-boot
+
+       # The device firmware needs revision 1 of EXT2
+       tune2fs -O filetype $@.tmp-boot
+       e2fsck -pDf $@.tmp-boot > /dev/null
+
+       ./dns313_gen_hdd_img.sh $@ $@.tmp-boot $(IMAGE_ROOTFS) \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 
        rm -rf $@.tmp
 endef
@@ -71,6 +89,8 @@ define Build/nas4220b-sq201-images
        cp $(IMAGE_KERNEL) $@.tmp/zImage
        cp ./ImageInfo-$(1) $@.tmp/ImageInfo
 
+       sed -i -e "s/DATESTR/`date +%Y%m%d $(if $(SOURCE_DATE_EPOCH),--date "@$(SOURCE_DATE_EPOCH)")`/g" $@.tmp/ImageInfo
+
        (cd $@.tmp; tar --sort=name --owner=0 --group=0 --numeric-owner -czf $@ * \
                $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)"))
 
@@ -95,6 +115,7 @@ define Device/Default
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
        BLOCKSIZE := 128k
+       SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
 # A reasonable set of default packages handling the NAS type
@@ -104,31 +125,48 @@ GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
                kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
                kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
                kmod-nls-utf8 kmod-usb-storage-extras \
-               samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
+               samba36-server mdadm cfdisk fdisk e2fsprogs badblocks \
+               partx-utils
 
+# The DIR-685 flash layout is kernel in WRGG format, padded and followed
+# by the appended rootfs followed by some reasonable JFFS padding, the
+# remainder will be used by JFFS2 through overlayfs.
+#
+# - For the factory image, the WRGG image includes the rootfs so that the
+#   default firmware will flash it properly as all it knows is WRGG format.
+# - For the sysupgrade, we do not include the rootfs in the kernel image
+#   so it is not needelessly tossed into the RAM by the boot loader.
+#   This will be flashed from OpenWrt userland anyways so we only need
+#   the minimum to make the boot loader happy.
 define Device/dlink_dir-685
        DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
        DEVICE_DTS := gemini-dlink-dir-685
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
                        kmod-switch-rtl8366rb swconfig \
-                       rt2800-pci
-       IMAGES := factory.bin
-       IMAGE/factory.bin := dir685-images
+                       kmod-rt2800-pci
+       IMAGES := factory.bin sysupgrade.bin
+       # Pad to 128k erase blocks with 160 bytes WRGG header
+       IMAGE/factory.bin := append-kernel | pad-offset 128k 160 | append-rootfs | dir685-pad-rootfs | dir685-image
+       IMAGE/sysupgrade.bin := append-kernel | pad-offset 128k 160 | dir685-image | append-rootfs | dir685-pad-rootfs | append-metadata
 endef
 TARGET_DEVICES += dlink_dir-685
 
 define Device/dlink_dns-313
        DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
        DEVICE_DTS := gemini-dlink-dns-313
+       DEVICE_TYPE := nas
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-       IMAGES := factory.bin
-       IMAGE/factory.bin := dns313-images
+       BLOCKSIZE := 1k
+       FILESYSTEMS := ext4
+       IMAGES := factory.bin.gz
+       IMAGE/factory.bin.gz := dns313-images | gzip
 endef
 TARGET_DEVICES += dlink_dns-313
 
 define Device/itian-raidsonic
        IMAGES := factory.bin
-       IMAGE/factory.bin := append-rootfs | pad-to 6144k | nas4220b-sq201-images $(1)
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
+               nas4220b-sq201-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
 
@@ -136,7 +174,7 @@ define Device/itian_sq201
        $(Device/itian-raidsonic)
        DEVICE_TITLE := ITian Square One SQ201
        DEVICE_DTS := gemini-sq201
-       DEVICE_PACKAGES += rt61-pci usb2-pci
+       DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
 endef
 TARGET_DEVICES += itian_sq201
 
@@ -144,16 +182,10 @@ define Device/raidsonic_ib-4220-b
        $(Device/itian-raidsonic)
        DEVICE_TITLE := Raidsonic NAS IB-4220-B
        DEVICE_DTS := gemini-nas4220b
+       DEVICE_TYPE := nas
 endef
 TARGET_DEVICES += raidsonic_ib-4220-b
 
-define Device/teltonika_rut1xx
-       DEVICE_TITLE := Teltonika RUT1xx
-       DEVICE_DTS := gemini-rut1xx
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
-endef
-TARGET_DEVICES += teltonika_rut1xx
-
 # The wiliboard images need some changes to be functional and buildable.
 #
 # The dts would need to use the ecoscentric,redboot-fis-partitions partition