refresh generic 2.6.25 patches to match upstream style
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 110-ipp2p_0.8.1rc1.patch
index 0ed18b404c28f9232ffc23d5a7105fbdcdcd092d..cd1abfaf6da2c547d33abbb1645cb8c25d0cf8b3 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ipt_ipp2p.h
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/include/linux/netfilter_ipv4/ipt_ipp2p.h
++++ b/include/linux/netfilter_ipv4/ipt_ipp2p.h
 @@ -0,0 +1,31 @@
 +#ifndef __IPT_IPP2P_H
 +#define __IPT_IPP2P_H
@@ -34,10 +32,8 @@ Index: linux-2.6.25.4/include/linux/netfilter_ipv4/ipt_ipp2p.h
 +#define IPP2P_MUTE            (1 << 14)
 +#define IPP2P_WASTE           (1 << 15)
 +#define IPP2P_XDCC            (1 << 16)
-Index: linux-2.6.25.4/net/ipv4/netfilter/ipt_ipp2p.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/net/ipv4/netfilter/ipt_ipp2p.c
++++ b/net/ipv4/netfilter/ipt_ipp2p.c
 @@ -0,0 +1,856 @@
 +#if defined(MODVERSIONS)
 +#include <linux/modversions.h>
@@ -895,11 +891,9 @@ Index: linux-2.6.25.4/net/ipv4/netfilter/ipt_ipp2p.c
 +module_exit(fini);
 +
 +
-Index: linux-2.6.25.4/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.25.4/net/ipv4/netfilter/Kconfig
-@@ -57,6 +57,12 @@ config IP_NF_IPTABLES
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -57,6 +57,12 @@
          To compile it as a module, choose M here.  If unsure, say N.
  
  # The matches.
@@ -912,11 +906,9 @@ Index: linux-2.6.25.4/net/ipv4/netfilter/Kconfig
  config IP_NF_MATCH_RECENT
        tristate '"recent" match support'
        depends on IP_NF_IPTABLES
-Index: linux-2.6.25.4/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.25.4.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.25.4/net/ipv4/netfilter/Makefile
-@@ -47,6 +47,8 @@ obj-$(CONFIG_IP_NF_MATCH_ECN) += ipt_ecn
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -47,6 +47,8 @@
  obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o