move the updated version (for 2.6.30+) of ar8216/mvswitch to the generic files direct...
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.28 / 690-phy_rtl8306.patch
index e88db16649dd38c44d9ff7c7fbc47f2a72f76854..b56d55b4597a39b5fd3817bdfb3101539a30f1de 100644 (file)
@@ -1,7 +1,7 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -88,6 +88,10 @@ config AR8216_PHY
-       tristate "Driver for Atheros AR8216 switches"
+@@ -81,6 +81,10 @@ config IP175C_PHY
+       tristate "Driver for IC+ IP175C/IP178C switches"
        select SWCONFIG
  
 +config RTL8306_PHY
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY)    += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY)   += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
  obj-$(CONFIG_IP175C_PHY)      += ip175c.o
- obj-$(CONFIG_AR8216_PHY)      += ar8216.o
 +obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o