Deprecate the old SPI-GPIO driver.
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.28 / 921-gpio_spi_driver.patch
index 6cab67a27aec09cefa4fec6a9938cf95f06bb18a..eb9155c8d785041f7ef5f26cbde89ce550dfc0f5 100644 (file)
@@ -1,5 +1,15 @@
---- /dev/null
-+++ b/include/linux/spi/spi_gpio.h
+THIS CODE IS DEPRECATED.
+
+Please use the new mainline SPI-GPIO driver, as of 2.6.29.
+
+--mb
+
+
+
+Index: linux-2.6.28.2/include/linux/spi/spi_gpio_old.h
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.28.2/include/linux/spi/spi_gpio_old.h    2009-02-10 17:14:33.000000000 +0100
 @@ -0,0 +1,73 @@
 +/*
 + * spi_gpio interface to platform code
 +int spi_gpio_next_id(void);
 +
 +#endif /* _LINUX_SPI_SPI_GPIO */
---- /dev/null
-+++ b/drivers/spi/spi_gpio.c
+Index: linux-2.6.28.2/drivers/spi/spi_gpio_old.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.28.2/drivers/spi/spi_gpio_old.c  2009-02-10 17:15:01.000000000 +0100
 @@ -0,0 +1,251 @@
 +/*
 + * Bitbanging SPI bus driver using GPIO API
 +#include <linux/platform_device.h>
 +#include <linux/spi/spi.h>
 +#include <linux/spi/spi_bitbang.h>
-+#include <linux/spi/spi_gpio.h>
++#include <linux/spi/spi_gpio_old.h>
 +#include <linux/gpio.h>
 +#include <asm/atomic.h>
 +
 +MODULE_AUTHOR("Michael Buesch");
 +MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
 +MODULE_LICENSE("GPL v2");
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
-@@ -100,6 +100,19 @@ config SPI_BUTTERFLY
+Index: linux-2.6.28.2/drivers/spi/Kconfig
+===================================================================
+--- linux-2.6.28.2.orig/drivers/spi/Kconfig    2009-02-10 17:13:57.000000000 +0100
++++ linux-2.6.28.2/drivers/spi/Kconfig 2009-02-10 17:14:33.000000000 +0100
+@@ -100,6 +100,15 @@ config SPI_BUTTERFLY
          inexpensive battery powered microcontroller evaluation board.
          This same cable can be used to flash new firmware.
  
-+config SPI_GPIO
-+      tristate "GPIO API based bitbanging SPI controller"
++config SPI_GPIO_OLD
++      tristate "Old GPIO API based bitbanging SPI controller (DEPRECATED)"
 +      depends on SPI_MASTER && GENERIC_GPIO
 +      select SPI_BITBANG
 +      help
-+        This is a platform driver that can be used for bitbanging
-+        an SPI bus over GPIO pins.
-+        Select this if you have any SPI device that is connected via
-+        GPIO pins.
-+        The module will be called spi_gpio.
++        This code is deprecated. Please use the new mainline SPI-GPIO driver.
 +
 +        If unsure, say N.
 +
  config SPI_IMX
        tristate "Freescale iMX SPI controller"
        depends on ARCH_IMX && EXPERIMENTAL
---- a/drivers/spi/Makefile
-+++ b/drivers/spi/Makefile
+Index: linux-2.6.28.2/drivers/spi/Makefile
+===================================================================
+--- linux-2.6.28.2.orig/drivers/spi/Makefile   2009-02-10 17:13:57.000000000 +0100
++++ linux-2.6.28.2/drivers/spi/Makefile        2009-02-10 17:14:33.000000000 +0100
 @@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN)                       += spi_bfin5xx.
  obj-$(CONFIG_SPI_BITBANG)             += spi_bitbang.o
  obj-$(CONFIG_SPI_AU1550)              += au1550_spi.o
  obj-$(CONFIG_SPI_BUTTERFLY)           += spi_butterfly.o
-+obj-$(CONFIG_SPI_GPIO)                        += spi_gpio.o
++obj-$(CONFIG_SPI_GPIO_OLD)            += spi_gpio_old.o
  obj-$(CONFIG_SPI_IMX)                 += spi_imx.o
  obj-$(CONFIG_SPI_LM70_LLP)            += spi_lm70llp.o
  obj-$(CONFIG_SPI_PXA2XX)              += pxa2xx_spi.o
---- a/MAINTAINERS
-+++ b/MAINTAINERS
-@@ -4027,6 +4027,11 @@ M:      jbglaw@lug-owl.de
- L:    linux-kernel@vger.kernel.org
- S:    Maintained
-+SPI GPIO MASTER DRIVER
-+P:    Michael Buesch
-+M:    mb@bu3sch.de
-+S:    Maintained
-+
- STABLE BRANCH
- P:    Greg Kroah-Hartman
- M:    greg@kroah.com