kernel: update 4.9 to 4.9.44
[openwrt/openwrt.git] / target / linux / generic / hack-4.9 / 930-crashlog.patch
index dfff4c78e8ec9fc04c281d6e63e429dce3b4c902..15d5ef4d679ee2920da163b5fac6921cfac817d8 100644 (file)
@@ -19,9 +19,6 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  create mode 100644 include/linux/crashlog.h
  create mode 100644 kernel/crashlog.c
 
-diff --git a/include/linux/crashlog.h b/include/linux/crashlog.h
-new file mode 100644
-index 000000000000..7a9ee6138cc4
 --- /dev/null
 +++ b/include/linux/crashlog.h
 @@ -0,0 +1,17 @@
@@ -42,8 +39,6 @@ index 000000000000..7a9ee6138cc4
 +#endif
 +
 +#endif
-diff --git a/init/Kconfig b/init/Kconfig
-index 9f2c0cabbc97..6d8f388fb9b3 100644
 --- a/init/Kconfig
 +++ b/init/Kconfig
 @@ -1298,6 +1298,10 @@ config RELAY
@@ -57,8 +52,6 @@ index 9f2c0cabbc97..6d8f388fb9b3 100644
  config BLK_DEV_INITRD
        bool "Initial RAM filesystem and RAM disk (initramfs/initrd) support"
        depends on BROKEN || !FRV
-diff --git a/kernel/Makefile b/kernel/Makefile
-index 314e7d62f5f0..5fe0d8c3cb35 100644
 --- a/kernel/Makefile
 +++ b/kernel/Makefile
 @@ -113,6 +113,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
@@ -69,9 +62,6 @@ index 314e7d62f5f0..5fe0d8c3cb35 100644
  
  $(obj)/configs.o: $(obj)/config_data.h
  
-diff --git a/kernel/crashlog.c b/kernel/crashlog.c
-new file mode 100644
-index 000000000000..11894b276e54
 --- /dev/null
 +++ b/kernel/crashlog.c
 @@ -0,0 +1,213 @@
@@ -288,11 +278,9 @@ index 000000000000..11894b276e54
 +      return 0;
 +}
 +module_init(crashlog_init_fs);
-diff --git a/kernel/module.c b/kernel/module.c
-index 80b5ac4181c6..51d6e4e6f436 100644
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -253,6 +253,9 @@ static void mod_update_bounds(struct module *mod)
+@@ -253,6 +253,9 @@ static void mod_update_bounds(struct mod
  #ifdef CONFIG_KGDB_KDB
  struct list_head *kdb_modules = &modules; /* kdb needs the list of modules */
  #endif /* CONFIG_KGDB_KDB */
@@ -302,8 +290,6 @@ index 80b5ac4181c6..51d6e4e6f436 100644
  
  static void module_assert_mutex(void)
  {
-diff --git a/mm/bootmem.c b/mm/bootmem.c
-index e8a55a3c9feb..e0f3c0bf2709 100644
 --- a/mm/bootmem.c
 +++ b/mm/bootmem.c
 @@ -14,6 +14,7 @@
@@ -314,7 +300,7 @@ index e8a55a3c9feb..e0f3c0bf2709 100644
  #include <linux/bug.h>
  #include <linux/io.h>
  #include <linux/bootmem.h>
-@@ -174,6 +175,7 @@ static unsigned long __init free_all_bootmem_core(bootmem_data_t *bdata)
+@@ -174,6 +175,7 @@ static unsigned long __init free_all_boo
        if (!bdata->node_bootmem_map)
                return 0;
  
@@ -322,8 +308,6 @@ index e8a55a3c9feb..e0f3c0bf2709 100644
        map = bdata->node_bootmem_map;
        start = bdata->node_min_pfn;
        end = bdata->node_low_pfn;
-diff --git a/mm/memblock.c b/mm/memblock.c
-index 68849d0ead09..aef9ca5e7f52 100644
 --- a/mm/memblock.c
 +++ b/mm/memblock.c
 @@ -19,6 +19,7 @@
@@ -334,7 +318,7 @@ index 68849d0ead09..aef9ca5e7f52 100644
  
  #include <asm/sections.h>
  #include <linux/io.h>
-@@ -499,6 +500,8 @@ static void __init_memblock memblock_insert_region(struct memblock_type *type,
+@@ -499,6 +500,8 @@ static void __init_memblock memblock_ins
        memblock_set_region_node(rgn, nid);
        type->cnt++;
        type->total_size += size;
@@ -343,7 +327,7 @@ index 68849d0ead09..aef9ca5e7f52 100644
  }
  
  /**
-@@ -538,6 +541,8 @@ int __init_memblock memblock_add_range(struct memblock_type *type,
+@@ -538,6 +541,8 @@ int __init_memblock memblock_add_range(s
                type->regions[0].flags = flags;
                memblock_set_region_node(&type->regions[0], nid);
                type->total_size = size;
@@ -352,6 +336,3 @@ index 68849d0ead09..aef9ca5e7f52 100644
                return 0;
        }
  repeat:
--- 
-2.11.0
-