ipq40xx: Remove SUPPORTED_DEVICES for A42
[openwrt/openwrt.git] / target / linux / ipq40xx / image / Makefile
index eb26082be7aec9331367a142316db077035c41f4..804cba254f4e4ea5a667475338ac23b9c6604d7f 100644 (file)
@@ -31,11 +31,30 @@ define Device/UbiFit
        IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
 endef
 
+
+define Device/asus_rt-ac58u
+       $(call Device/FitImageLzma)
+       DEVICE_DTS := qcom-ipq4018-rt-ac58u
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DTB_SIZE := 65536
+       DEVICE_TITLE := Asus RT-AC58U
+       IMAGE_SIZE := 20439364
+       FILESYSTEMS := squashfs
+#      Someone - in their infinite wisdom - decided to put the firmware
+#      version in front of the image name \03\00\00\04 => Version 3.0.0.4
+#      Since u-boot works with strings we either need another fixup step
+#      to add a version... or we are very careful not to add '\0' into that
+#      string and call it a day.... Yeah, we do the latter!
+       UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC58U')
+       IMAGES := sysupgrade.bin
+       DEVICE_PACKAGES := ipq-wifi-asus_rt-ac58u kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += asus_rt-ac58u
+
 define Device/avm_fritzbox-4040
        $(call Device/FitImageLzma)
        DEVICE_DTS := qcom-ipq4019-fritz4040
-       BLOCKSIZE := 4k
-       PAGESIZE := 256
        BOARD_NAME := fritz4040
        DEVICE_TITLE := AVM Fritz!Box 4040
        IMAGE_SIZE := 29753344
@@ -45,25 +64,48 @@ define Device/avm_fritzbox-4040
 endef
 TARGET_DEVICES += avm_fritzbox-4040
 
+define Device/compex_wpj428
+       $(call Device/FitImage)
+       DEVICE_DTS := qcom-ipq4028-wpj428
+       DEVICE_DTS_CONFIG := config@4
+       BLOCKSIZE := 64k
+       DEVICE_TITLE := Compex WPJ428
+       IMAGE_SIZE := 31232k
+       KERNEL_SIZE := 4096k
+       IMAGES = sysupgrade.bin
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := ath10k-firmware-qca4019 kmod-gpio-beeper
+endef
+TARGET_DEVICES += compex_wpj428
+
 define Device/glinet_gl-b1300
+       $(call Device/FitImage)
        DEVICE_TITLE := GL.iNet GL-B1300
        BOARD_NAME := gl-b1300
-       DEVICE_DTS := qcom-ipq4019-gl-b1300
-       KERNEL_INSTALL := 1
+       DEVICE_DTS := qcom-ipq4029-gl-b1300
        KERNEL_SIZE := 4096k
        IMAGE_SIZE := 26624k
-       $(call Device/FitImage)
        IMAGES := sysupgrade.bin
-       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
+       IMAGE/sysupgrade.bin := append-kernel |append-rootfs | pad-rootfs | append-metadata
        DEVICE_PACKAGES := ipq-wifi-glinet_gl-b1300
 endef
 TARGET_DEVICES += glinet_gl-b1300
 
+define Device/meraki_mr33
+       $(call Device/FitImage)
+       DEVICE_DTS := qcom-ipq4029-mr33
+       BLOCKSIZE := 131072
+       PAGESIZE := 2048
+       DEVICE_TITLE := Cisco Meraki MR33
+       IMAGES = sysupgrade.bin
+       DEVICE_PACKAGES := -swconfig ipq-wifi-meraki_mr33 ath10k-firmware-qca9887
+endef
+TARGET_DEVICES += meraki_mr33
+
 define Device/openmesh_a42
        $(call Device/FitImageLzma)
        DEVICE_DTS := qcom-ipq4018-a42
        BLOCKSIZE := 64k
-       SUPPORTED_DEVICES := openmesh,a42
        DEVICE_TITLE := OpenMesh A42
        KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
        IMAGE_SIZE := 15616k