ipq40xx: ipq4019: Add new device Compex WPJ419
[openwrt/openwrt.git] / target / linux / ipq40xx / image / Makefile
index ed46bca6490b4e1fda2718720fb9bcf8975ce9a0..ef80e68393625fd4239ddf3cb993431cad83cc23 100644 (file)
@@ -164,6 +164,20 @@ define Device/avm_fritzrepeater-3000
 endef
 TARGET_DEVICES += avm_fritzrepeater-3000
 
+define Device/compex_wpj419
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Compex
+       DEVICE_MODEL := WPJ419
+       DEVICE_DTS := qcom-ipq4019-wpj419
+       DEVICE_DTS_CONFIG := config@12
+       KERNEL_INSTALL := 1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       FILESYSTEMS := squashfs
+endef
+TARGET_DEVICES += compex_wpj419
+
 define Device/compex_wpj428
        $(call Device/FitImage)
        DEVICE_VENDOR := Compex