ipq806x: add ipq4019 support
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index 45f83ddcdfa4f1c70fa9ea3625ccf7d803b4f4a3..3a65d334aaf588f77846f04660f1c59e0fa8c855 100644 (file)
@@ -5,18 +5,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs nand ubifs
-CPU_TYPE:=cortex-a7
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs nand ubifs fpu
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.4
 
 KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform
-
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
+       kmod-ath10k wpad-mini \
+       uboot-envtools
 
 $(eval $(call BuildTarget))