ipq806x: ipq4019: add ap-dk01.1-c1 board support
[openwrt/openwrt.git] / target / linux / ipq806x / image / Makefile
index c9f5a7ba6c646ee02987c6382ef2d2e1c9908abf..aeea04cefd235f2eb7ab0840a9bc46531d1f3282 100644 (file)
@@ -251,6 +251,22 @@ define Device/VR2600v
        IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
 endef
 
+define Device/AP-DK01.1-C1
+       PROFILES += $$(DEVICE_NAME)
+       DEVICE_TITLE := QCA AP-DK01.1-C1
+       BOARD_NAME := ap-dk01.1-c1
+       DEVICE_DTS := qcom-ipq4019-ap.dk01.1-c1
+       KERNEL_LOADADDR := 0x80208000
+       KERNEL_INSTALL := 1
+       KERNEL_SIZE := 4096k
+       IMAGE_SIZE := 26624k
+       FILESYSTEMS := squashfs
+       $(call Device/FitImage)
+       IMAGES := sysupgrade.bin
+       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := ath10k-firmware-qca4019
+endef
+
 define Device/AP-DK04.1-C1
        $(call Device/FitImage)
        $(call Device/UbiFit)
@@ -265,6 +281,6 @@ define Device/AP-DK04.1-C1
 endef
 
 TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 FRITZ4040 R7500 \
-                 R7500v2 R7800 NBG6817 VR2600v AP-DK04.1-C1
+                 R7500v2 R7800 NBG6817 VR2600v AP-DK01.1-C1 AP-DK04.1-C1
 
 $(eval $(call BuildImage))