ipq806x: add support for Buffalo WXR-2533DHP
[openwrt/openwrt.git] / target / linux / ipq806x / image / Makefile
index 2902af3231a87592e9c040e7e7e1e4e1958a01a5..e1eb090de3d2b727c5367f957320c59964005900 100644 (file)
@@ -3,6 +3,13 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+define Build/buffalo-rootfs-cksum
+       ( \
+               echo -ne "\x$$(od -A n -t u1 $@ | tr -s ' ' '\n' | \
+                       $(STAGING_DIR_HOST)/bin/awk '{s+=$$0}END{printf "%x", 255-s%256}')"; \
+       ) >> $@
+endef
+
 define Device/Default
        PROFILES := Default
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
@@ -67,12 +74,26 @@ define Device/ZyXELImage
        KERNEL_SUFFIX := -uImage
        KERNEL = kernel-bin | append-dtb | uImage none | pad-to $${KERNEL_SIZE}
        KERNEL_NAME := zImage
-       IMAGES := sysupgrade.bin mmcblk0p5-rootfs.bin mmcblk0p4-kernel.bin
+       IMAGES := factory.bin sysupgrade.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to $$$$(BLOCKSIZE) | zyxel-ras-image separate-kernel
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$${BLOCKSIZE} | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       IMAGE/mmcblk0p5-rootfs.bin := append-rootfs | pad-rootfs | pad-to $$$${BLOCKSIZE}
-       IMAGE/mmcblk0p4-kernel.bin := append-kernel
 endef
 
+define Device/buffalo_wxr-2533dhp
+       $(call Device/LegacyImage)
+       DEVICE_DTS := qcom-ipq8064-wxr-2533dhp
+       DEVICE_TITLE := Buffalo WXR-2533DHP
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       IMAGE_SIZE := 65536k
+       KERNEL_IN_UBI := 1
+       IMAGES := sysupgrade.bin
+       IMAGE/sysupgrade.bin := append-rootfs | buffalo-rootfs-cksum | \
+               sysupgrade-tar rootfs=$$$$@ | append-metadata
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
+endef
+TARGET_DEVICES += buffalo_wxr-2533dhp
+
 define Device/compex_wpq864
        $(call Device/FitImage)
        $(call Device/UbiFit)
@@ -97,7 +118,7 @@ define Device/linksys_ea8500
        IMAGES := factory.bin sysupgrade.bin
        IMAGE/factory.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-ubi
        DEVICE_TITLE := Linksys EA8500
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
 endef
 TARGET_DEVICES += linksys_ea8500
 
@@ -109,7 +130,7 @@ define Device/nec_wg2600hp
        DEVICE_TITLE := NEC Aterm WG2600HP
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
 endef
 TARGET_DEVICES += nec_wg2600hp
 
@@ -124,7 +145,7 @@ define Device/netgear_d7800
        BOARD_NAME := d7800
        SUPPORTED_DEVICES += d7800
        DEVICE_TITLE := Netgear Nighthawk X4 D7800
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
 endef
 TARGET_DEVICES += netgear_d7800
 
@@ -139,7 +160,7 @@ define Device/netgear_r7500
        BOARD_NAME := r7500
        SUPPORTED_DEVICES += r7500
        DEVICE_TITLE := Netgear Nighthawk X4 R7500
-       DEVICE_PACKAGES := ath10k-firmware-qca988x
+       DEVICE_PACKAGES := ath10k-firmware-qca988x-ct
 endef
 TARGET_DEVICES += netgear_r7500
 
@@ -154,7 +175,7 @@ define Device/netgear_r7500v2
        BOARD_NAME := r7500v2
        SUPPORTED_DEVICES += r7500v2
        DEVICE_TITLE := Netgear Nighthawk X4 R7500v2
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0 ath10k-firmware-qca988x
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct ath10k-firmware-qca988x-ct
 endef
 TARGET_DEVICES += netgear_r7500v2
 
@@ -169,7 +190,7 @@ define Device/netgear_r7800
        BOARD_NAME := r7800
        SUPPORTED_DEVICES += r7800
        DEVICE_TITLE := Netgear Nighthawk X4S R7800
-       DEVICE_PACKAGES := ath10k-firmware-qca9984
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
 endef
 TARGET_DEVICES += netgear_r7800
 
@@ -183,7 +204,7 @@ define Device/qcom_ipq8064-ap148
        BOARD_NAME := ap148
        SUPPORTED_DEVICES += ap148
        DEVICE_TITLE := Qualcomm AP148
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
 endef
 TARGET_DEVICES += qcom_ipq8064-ap148
 
@@ -196,17 +217,30 @@ define Device/qcom_ipq8064-ap148-legacy
        BOARD_NAME := ap148
        SUPPORTED_DEVICES := qcom,ipq8064-ap148 ap148
        DEVICE_TITLE := Qualcomm AP148 (legacy)
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
 endef
 TARGET_DEVICES += qcom_ipq8064-ap148-legacy
 
+define Device/qcom_ipq8064-ap161
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_DTS := qcom-ipq8064-ap161
+       KERNEL_INSTALL := 1
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       BOARD_NAME := ap161
+       DEVICE_TITLE := Qualcomm AP161
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
+endef
+TARGET_DEVICES += qcom_ipq8064-ap161
+
 define Device/qcom_ipq8064-db149
        $(call Device/FitImage)
        DEVICE_DTS := qcom-ipq8064-db149
        KERNEL_INSTALL := 1
        BOARD_NAME := db149
        DEVICE_TITLE := Qualcomm DB149
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
 endef
 TARGET_DEVICES += qcom_ipq8064-db149
 
@@ -219,7 +253,7 @@ define Device/tplink_c2600
        SUPPORTED_DEVICES += c2600
        TPLINK_BOARD_ID := C2600
        DEVICE_TITLE := TP-Link Archer C2600
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
 endef
 TARGET_DEVICES += tplink_c2600
 
@@ -234,7 +268,7 @@ define Device/tplink_vr2600v
        BOARD_NAME := vr2600v
        SUPPORTED_DEVICES += vr2600v
        DEVICE_TITLE := TP-Link Archer VR2600v
-       DEVICE_PACKAGES := ath10k-firmware-qca99x0
+       DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
 endef
@@ -245,9 +279,12 @@ define Device/zyxel_nbg6817
        KERNEL_SIZE := 4096k
        BLOCKSIZE := 64k
        BOARD_NAME := nbg6817
+       RAS_BOARD := NBG6817
+       RAS_ROOTFS_SIZE := 20934k
+       RAS_VERSION := "V1.99(OWRT.9999)C0"
        SUPPORTED_DEVICES += nbg6817
        DEVICE_TITLE := ZyXEL NBG6817
-       DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs kmod-fs-ext4 losetup
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct e2fsprogs kmod-fs-ext4 losetup
        $(call Device/ZyXELImage)
 endef
 TARGET_DEVICES += zyxel_nbg6817