target/ixp4xx: fix image building after r20834 (closes: #7157)
[openwrt/openwrt.git] / target / linux / ixp4xx / image / Makefile
index da8f0fdde6c446120a43471b7a4cb95d422aeecc..6108e9166deba4660752edebabb7dda318b46840 100644 (file)
@@ -37,7 +37,7 @@ endef
 
 define Image/BuildKernel
        cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
-       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
+       BIN_DIR=$(BIN_DIR) IMG_PREFIX="$(IMG_PREFIX)" $(TOPDIR)/scripts/arm-magic.sh
 endef
 
 define Image/Build