ixp4xx patches cleanup, round one
[openwrt/openwrt.git] / target / linux / ixp4xx / patches-2.6.26 / 030-ixp4xx_fsg_board_support.patch
index 8fb7280e079bca32e8d88967840d37f727414556..048b9f7465a9a234662642805bad54f67ed39b7b 100644 (file)
@@ -1,50 +1,3 @@
-From: Rod Whitby <rod@whitby.id.au>
-Subject: [PATCH] ixp4xx: Add support for the Freecom FSG-3 board (Patch #4874)
-
-The Freecom-FSG3 is a small network-attached-storage device with the
-following feature set:
-
-* Intel IXP422
-* 4MB Flash (ixp4xx flash driver)
-* 64MB RAM
-* 4 USB 2.0 host ports (ehci and ohci drivers)
-* 1 WAN (eth1) and 3 LAN (eth0) ethernet ports
-  * Supported by the open source ixp4xx ethernet driver
-* Via VT6421 disk controller (libata and sata-via drivers)
-  * Internal hard disk (PATA supported, SATA not yet supported)
-  * External SATA port (not yet supported)
-* ISL1208 RTC chip
-* Winbond 83782 temp sensor and fan controller
-* MiniPCI slot
-
-The ixp4xx_defconfig is also updated to support this device (the
-leds-fsg driver is to be submitted separately via the leds tree after
-this initial support is merged, as it depends on header gpio defines).
-
-Signed-off-by: Rod Whitby <rod@whitby.id.au>
-
-PATCH FOLLOWS
-KernelVersion: v2.6.25-rc6-74-g264e3e8
----
-
-Updated to correct all issues found by RMK.
-
-The front power button calls ctrl_alt_del() and the rear reset button
-now calls machine_restart() directly.
-
- arch/arm/configs/ixp4xx_defconfig      |    9 +-
- arch/arm/mach-ixp4xx/Kconfig           |    9 +
- arch/arm/mach-ixp4xx/Makefile          |    2 +
- arch/arm/mach-ixp4xx/fsg-pci.c         |   71 ++++++++
- arch/arm/mach-ixp4xx/fsg-setup.c       |  276 ++++++++++++++++++++++++++++++++
- include/asm-arm/arch-ixp4xx/fsg.h      |   50 ++++++
- include/asm-arm/arch-ixp4xx/hardware.h |    1 +
- include/asm-arm/arch-ixp4xx/irqs.h     |    7 +
- 8 files changed, 421 insertions(+), 4 deletions(-)
- create mode 100644 arch/arm/mach-ixp4xx/fsg-pci.c
- create mode 100644 arch/arm/mach-ixp4xx/fsg-setup.c
- create mode 100644 include/asm-arm/arch-ixp4xx/fsg.h
-
 --- a/arch/arm/configs/ixp4xx_defconfig
 +++ b/arch/arm/configs/ixp4xx_defconfig
 @@ -165,6 +165,7 @@