resync patches
[openwrt/openwrt.git] / target / linux / ixp4xx / patches-2.6.26 / 120-compex_support.patch
index 76111fd53b45bbf4864dd9ed4a4285a88411ac6a..0076db28995a25397c4482525d41be116befe786 100644 (file)
@@ -1,8 +1,8 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -81,6 +81,14 @@
- config MACH_PRONGHORNMETRO
-       def_bool MACH_PRONGHORN
+@@ -89,6 +89,14 @@
+         Engineering Sidewinder board. For more information on this
+         platform, see http://www.adiengineering.com
  
 +config MACH_COMPEX
 +      bool "Compex WP18 / NP18A"
        help
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -18,6 +18,7 @@
- obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
+@@ -19,6 +19,7 @@
  obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
  obj-pci-$(CONFIG_MACH_PRONGHORN)      += pronghorn-pci.o
+ obj-pci-$(CONFIG_MACH_SIDEWINDER)     += sidewinder-pci.o
 +obj-pci-$(CONFIG_MACH_COMPEX)         += ixdp425-pci.o
  
  obj-y += common.o
  
-@@ -34,6 +35,7 @@
- obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
+@@ -36,6 +37,7 @@
  obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
  obj-$(CONFIG_MACH_PRONGHORN)  += pronghorn-setup.o
+ obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
 +obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o