uclient: update to Git HEAD (2024-04-19)
[openwrt/openwrt.git] / target / linux / kirkwood / Makefile
index 4739760dec2ca9a09ea8bfc278b5987d912a1fbd..44eaf925a18eb5d8118a25e74f423d241bdafcda 100644 (file)
@@ -1,24 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2009-2015 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=targz usb jffs2_nand
+FEATURES:=rtc usb nand squashfs ramdisk
 CPU_TYPE:=xscale
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=6.1
+KERNEL_TESTING_PATCHVER:=6.6
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools kmod-usb2
 
 $(eval $(call BuildTarget))