mpc85xx: fix address config for ws-ap3825i
[openwrt/openwrt.git] / target / linux / kirkwood / Makefile
index 8d2a7c25cc43c7645cdb6331f40ba654900d7c56..44eaf925a18eb5d8118a25e74f423d241bdafcda 100644 (file)
@@ -1,25 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2009-2015 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=targz usb jffs2
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+FEATURES:=rtc usb nand squashfs ramdisk
+CPU_TYPE:=xscale
+SUBTARGETS:=generic
 
-LINUX_VERSION:=2.6.35.7
+KERNEL_PATCHVER:=6.1
+KERNEL_TESTING_PATCHVER:=6.6
 
 include $(INCLUDE_DIR)/target.mk
 
-CFLAGS:=-Os -pipe -march=armv5te -mtune=marvell-f -funit-at-a-time
-
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools kmod-usb2
 
 $(eval $(call BuildTarget))