kirkwood: sort occurrences of boardame alphabetically
[openwrt/openwrt.git] / target / linux / kirkwood / image / Makefile
index 2c4ad208f2740c3c54a406c27a88a896e1506495..39d93275f4a8507ab9f2b58a2afc6afb815f441e 100644 (file)
@@ -5,16 +5,10 @@
 # See /LICENSE for more information.
 #
 
-NAND_BLOCKSIZE := 2048-128k
-
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR:=0x8000
-TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect pogo_e02 ib62x0
-
-UBI_OPTS := -m 2048 -p 128KiB -s 512
-UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
 
 define Device/Default
   PROFILES := Default
@@ -22,73 +16,124 @@ define Device/Default
   KERNEL := kernel-bin | append-dtb | uImage none
   KERNEL_NAME := zImage
   KERNEL_SUFFIX  := -uImage
-  KERNEL_INSTALL := 1
+  KERNEL_IN_UBI := 1
 
   PAGESIZE := 2048
   SUBPAGESIZE := 512
   BLOCKSIZE := 128k
-  IMAGES := sysupgrade.tar
+  IMAGES := sysupgrade.bin factory.bin
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+  IMAGE/factory.bin := append-ubi
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+endef
+
+define Device/cisco_on100
+  DEVICE_TITLE := Cisco Systems ON100
+  DEVICE_DTS := kirkwood-on100
+  DEVICE_PACKAGES := kmod-i2c-mv64xxx
+  KERNEL_SIZE := 5376k
+  KERNEL_IN_UBI := 0
   UBINIZE_OPTS := -E 5
-  IMAGE/sysupgrade.tar := sysupgrade-tar
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+  BOARD_NAME := on100
 endef
+TARGET_DEVICES += cisco_on100
 
-define Device/dockstar
-  DEVICE_DTS := kirkwood-dockstar
-  FILESYSTEMS := squashfs
-  DEVICE_TITLE := Seagate FreeAgent Dockstar
-  IMAGES += factory.bin
-  IMAGE/factory.bin := append-ubi
-  KERNEL_IN_UBI := 1
+define Device/cloudengines_pogoe02
+  DEVICE_TITLE := Cloud Engines Pogoplug E02
+  DEVICE_DTS := kirkwood-pogo_e02
+  BOARD_NAME := pogo_e02
+  SUPPORTED_DEVICES += pogo_e02
 endef
+TARGET_DEVICES += cloudengines_pogoe02
 
-define Device/goflexnet
-$(Device/dockstar)
-  DEVICE_TITLE := Seagate GoFlexNet
-  DEVICE_DTS := kirkwood-goflexnet
+define Device/cloudengines_pogoplugv4
+  DEVICE_TITLE := Cloud Engines Pogoplug V4
+  DEVICE_DTS := kirkwood-pogoplug-series-4
+  DEVICE_PACKAGES := kmod-usb3
 endef
+TARGET_DEVICES += cloudengines_pogoplugv4
 
-define Device/goflexhome
-$(Device/dockstar)
-  DEVICE_TITLE := Seagate GoFlexHome
-  DEVICE_DTS := kirkwood-goflexhome
+define Device/iom_iconnect-1.1
+  DEVICE_TITLE := Iomega Iconnect
+  DEVICE_DTS := kirkwood-iconnect
+  BOARD_NAME := iconnect
+  SUPPORTED_DEVICES += iconnect
 endef
+TARGET_DEVICES += iom_iconnect-1.1
 
-define Device/linksys-audi
+define Device/linksys_audi
   DEVICE_TITLE := Linksys EA3500 (Audi)
   DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-mini
   DEVICE_DTS := kirkwood-linksys-audi
   KERNEL_SIZE := 2624k
-  FILESYSTEMS := squashfs
-  IMAGES += factory.bin
+  KERNEL_IN_UBI := 0
+  UBINIZE_OPTS := -E 5
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+  BOARD_NAME := linksys-audi
+  SUPPORTED_DEVICES += linksys-audi
 endef
+TARGET_DEVICES += linksys_audi
 
-define Device/linksys-viper
+define Device/linksys_viper
   DEVICE_TITLE := Linksys E4200v2 / EA4500 (Viper)
   DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-mini
   DEVICE_DTS := kirkwood-linksys-viper
   KERNEL_SIZE := 2688k
-  FILESYSTEMS := squashfs
-  IMAGES += factory.bin
+  KERNEL_IN_UBI := 0
+  UBINIZE_OPTS := -E 5
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+  BOARD_NAME := linksys-viper
+  SUPPORTED_DEVICES += linksys-viper
 endef
+TARGET_DEVICES += linksys_viper
 
-define Device/iconnect
-$(Device/dockstar)
-  DEVICE_TITLE := Iomega Iconnect
-  DEVICE_DTS := kirkwood-iconnect
+define Device/raidsonic_ib-nas62x0
+  DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
+  DEVICE_DTS := kirkwood-ib62x0
+  BOARD_NAME := ib62x0
+  SUPPORTED_DEVICES += ib62x0
 endef
+TARGET_DEVICES += raidsonic_ib-nas62x0
 
-define Device/pogo_e02
-$(Device/dockstar)
-  DEVICE_TITLE := Cloud Engines Pogoplug E02
-  DEVICE_DTS := kirkwood-pogo_e02
+define Device/seagate_dockstar
+  DEVICE_DTS := kirkwood-dockstar
+  DEVICE_TITLE := Seagate FreeAgent Dockstar
+  BOARD_NAME := dockstar
+  SUPPORTED_DEVICES += dockstar
 endef
+TARGET_DEVICES += seagate_dockstar
 
-define Device/ib62x0
-$(Device/dockstar)
-  DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
-  DEVICE_DTS := kirkwood-ib62x0
+define Device/seagate_goflexnet
+  DEVICE_TITLE := Seagate GoFlexNet
+  DEVICE_DTS := kirkwood-goflexnet
+  BOARD_NAME := goflexnet
+  SUPPORTED_DEVICES += goflexnet
+endef
+TARGET_DEVICES += seagate_goflexnet
+
+define Device/seagate_goflexhome
+  DEVICE_TITLE := Seagate GoFlexHome
+  DEVICE_DTS := kirkwood-goflexhome
+  BOARD_NAME := goflexhome
+  SUPPORTED_DEVICES += goflexhome
+endef
+TARGET_DEVICES += seagate_goflexhome
+
+define Device/zyxel_nsa310b
+  DEVICE_TITLE := ZyXEL NSA310b
+  DEVICE_DTS := kirkwood-nsa310b
+  DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
+  BOARD_NAME := nsa310b
+endef
+TARGET_DEVICES += zyxel_nsa310b
+
+define Device/zyxel_nsa325
+  DEVICE_TITLE := ZyXEL NSA325 (v1 and v2)
+  DEVICE_DTS := kirkwood-nsa325
+  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
+  BOARD_NAME := nsa325
 endef
+TARGET_DEVICES += zyxel_nsa325
 
 $(eval $(call BuildImage))