lantiq: add Amazon-SE subtarget
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 412b7b19c66ed3ac83e4696bf1b0c80391f5694c..a92e181bcf8da9703ae1d9452f11f1dc78c2c1da 100644 (file)
@@ -6,21 +6,18 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.39
-#LINUX_VERSION:=2.6.32.33
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))