lantiq: add Amazon-SE subtarget
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index dced25ffdd31af2590cd65c5540359abae886786..a92e181bcf8da9703ae1d9452f11f1dc78c2c1da 100644 (file)
@@ -6,15 +6,13 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.1.9
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Lantiq SoC