use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index ce0f0dc753df3ad88986a877548b46ae78ce0f82..d3721f6c2cd9567777089ee483b4cb69dd90335a 100644 (file)
@@ -7,13 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS=xway ase falcon
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.7.10
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC