uclient: update to Git HEAD (2024-04-19)
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 8d845b95a78afbb8005829051bb2c8f886ef9245..2e166a5f373902f95aea5a2a1e1c68951e5d54c5 100644 (file)
@@ -1,20 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2007-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
-
-LINUX_VERSION:=3.0.3
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+KERNEL_PATCHVER:=5.15
 
 define Target/Description
        Build firmware images for Lantiq SoC