mpc85xx: fix address config for ws-ap3825i
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 9858c720d3e1db489ae8785162e445a053353150..2e166a5f373902f95aea5a2a1e1c68951e5d54c5 100644 (file)
@@ -1,21 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2007-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS:=danube ar9 vr9 falcon svip_be
-LINUX_VERSION:=3.3.8
-
-#SUBTARGETS=xway ase
-#LINUX_VERSION:=3.6.8
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+KERNEL_PATCHVER:=5.15
 
 define Target/Description
        Build firmware images for Lantiq SoC