lantiq: fix VG3503J partition table for newer kernels
[openwrt/openwrt.git] / target / linux / lantiq / image / Makefile
index 82f0e6f3272c50a56afcd96a8a6eb549785a9455..08d80ecb1d80486068b5e8ec9e0c4c1ccb9c44d6 100644 (file)
@@ -156,7 +156,7 @@ endif
 endef
 
 define Image/BuildLoader/squashfs
-       dd if=$(KDIR)/loader-$(2).bin of=$(KDIR)/loader-$(2).bin.padded bs=1536k conv=sync
+       dd if=$(KDIR)/loader-$(2).bin of=$(KDIR)/loader-$(2).bin.padded bs=3072k conv=sync
        cat $(KDIR)/loader-$(2).bin.padded $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
        $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image)
 endef