lantiq: fix DM200 boot with fake uImage headers
[openwrt/openwrt.git] / target / linux / lantiq / image / Makefile
index e52e43c6e59e4dc58c57a3b72617853e03c0d3f7..3541ca8b54d449ba3aecaab0d7b87ae79ff58ee4 100644 (file)
@@ -101,6 +101,7 @@ endef
 
 define Device/AVM
   KERNEL := kernel-bin | append-dtb | lzma | eva-image
+  KERNEL_INITRAMFS := $$(KERNEL)
   IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-avm-fakeroot | \
        append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
 endef
@@ -583,6 +584,10 @@ TARGET_DEVICES += bt_homehub-v5a
 define Device/netgear_dm200
   DEVICE_DTS := DM200
   IMAGES := sysupgrade.bin factory.img
+  IMAGE/sysupgrade.bin := append-kernel | \
+       pad-offset 64k 64 | append-uImage-fakeroot-hdr | \
+       pad-offset 64k 64 | append-uImage-fakeroot-hdr | \
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.img := $$(IMAGE/sysupgrade.bin) | netgear-dni
   IMAGE_SIZE := 7872k
   DEVICE_TITLE := Netgear DM200