layerscape: support ubifs rootfs
[openwrt/openwrt.git] / target / linux / layerscape / Makefile
index f511407f918428cca0aa110b2fd826c2e9df2aa1..f533767fa6c035609f98c1a2d53e902555cc546a 100644 (file)
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
 DEVICE_TYPE:=developerboard
-KERNEL_PATCHVER:=4.4
-KERNELNAME:=Image dtbs
-FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=64b 32b
-MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.9
+FEATURES:=squashfs nand usb pcie gpio fpu ubifs
+SUBTARGETS:=armv8_64b armv8_32b
+MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
 
 define Target/Description
-       Build firmware images for $(BOARDNAME) SoC devices.
+       Build firmware images for NXP Layerscape based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
 
 $(eval $(call BuildTarget))