layerscape: support ubifs rootfs
[openwrt/openwrt.git] / target / linux / layerscape / image / Makefile
index 85a6b822eb47095ce7f4203c57da7f4f091699e6..fc76ddd2ef745fcf37342b5d12644a1cae27f305 100644 (file)
@@ -16,6 +16,10 @@ define Build/append-ls-uboot
        dd if=$(STAGING_DIR_IMAGE)/$(1)-$(SUBTARGET)-uboot.bin >> $@
 endef
 
+define Build/append-ls-ppa
+       dd if=$(STAGING_DIR_IMAGE)/$(1)-ppa.itb >> $@
+endef
+
 define Build/append-ls-fman
        dd if=$(STAGING_DIR_IMAGE)/$(1)-fman.bin >> $@
 endef
@@ -41,11 +45,6 @@ define Build/append-ls-dtb
        dd if=$(DTS_DIR)/$(1).dtb >> $@
 endef
 
-define Build/append-ls-rootfs-ext4
-       $(STAGING_DIR_HOST)/bin/make_ext4fs -l $(word 2,$(1)) -b 4096 -i 6000 -m 0 -J $(KDIR)/$(word 1,$(1))-$(word 2,$(1)).root.ext4 $(TARGET_DIR)
-       dd if=$(KDIR)/$(word 1,$(1))-$(word 2,$(1)).root.ext4 >> $@
-endef
-
 define Device/Default
   PROFILES = Default
   FILESYSTEMS := squashfs
@@ -67,10 +66,12 @@ endef
 
 define Device/ls1043ardb
   DEVICE_TITLE := ls1043ardb-$(SUBTARGET)
-  DEVICE_PACKAGES += rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb fman-layerscape-ls1043ardb
+  DEVICE_PACKAGES +=   rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb \
+                       fman-layerscape-ls1043ardb layerscape-ppa-ls1043ardb
   DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1043a-rdb-sdk
   IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
-                       append-ls-uboot $(1) | pad-to 9M | \
+                       append-ls-uboot $(1) | pad-to 4M | \
+                       append-ls-ppa $(1) | pad-to 9M | \
                        append-ls-fman $(1) | pad-to 15M | \
                        append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
                        append-kernel | pad-to 32M | \
@@ -80,55 +81,97 @@ TARGET_DEVICES += ls1043ardb
 
 define Device/ls1046ardb
   DEVICE_TITLE := ls1046ardb-$(SUBTARGET)
-  DEVICE_PACKAGES += rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb fman-layerscape-ls1046ardb
+  DEVICE_PACKAGES +=   rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb \
+                       fman-layerscape-ls1046ardb layerscape-ppa-ls1046ardb
   DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1046a-rdb-sdk
+  FILESYSTEMS := ubifs
+  UBIFS_OPTS := -m 1 -e 262016 -c 128
+  UBINIZE_OPTS := -E 5
+  BLOCKSIZE := 256KiB
+  PAGESIZE := 1
   IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
-                       append-ls-uboot $(1) | pad-to 9M | \
+                       append-ls-uboot $(1) | pad-to 4M | \
+                       append-ls-ppa $(1) | pad-to 9M | \
                        append-ls-fman $(1) | pad-to 15M | \
                        append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
                        append-kernel | pad-to 32M | \
-                       append-ls-rootfs-ext4 $(1) 22M | check-size 67108865
+                       append-ubi | check-size 67108865
 endef
 TARGET_DEVICES += ls1046ardb
 
 define Device/ls1012ardb
   DEVICE_TITLE := ls1012ardb-$(SUBTARGET)
   DEVICE_PACKAGES +=   rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb \
-                       kmod-ppfe layerscape-ppfe
+                       kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012ardb
   DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
+  FILESYSTEMS := ubifs
+  UBIFS_OPTS := -m 1 -e 262016 -c 128
+  UBINIZE_OPTS := -E 5
+  BLOCKSIZE := 256KiB
+  PAGESIZE := 1
   IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
-                       append-ls-uboot $(1) | pad-to 10M | \
+                       append-ls-uboot $(1) | pad-to 4M | \
+                       append-ls-ppa $(1) | pad-to 10M | \
                        append-ls-ppfe | pad-to 15M | \
                        append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
                        append-kernel | pad-to 32M | \
-                       append-ls-rootfs-ext4 $(1) 23M | check-size 67108865
+                       append-ubi | check-size 67108865
 endef
 TARGET_DEVICES += ls1012ardb
 
+define Device/ls1012afrdm
+  DEVICE_TITLE := ls1012afrdm-$(SUBTARGET)
+  DEVICE_PACKAGES +=   rcw-layerscape-ls1012afrdm uboot-layerscape-$(SUBTARGET)-ls1012afrdm \
+                       kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012afrdm
+  DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-frdm
+  FILESYSTEMS := ubifs
+  UBIFS_OPTS := -m 1 -e 262016 -c 128
+  UBINIZE_OPTS := -E 5
+  BLOCKSIZE := 256KiB
+  PAGESIZE := 1
+  IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
+                       append-ls-uboot $(1) | pad-to 4M | \
+                       append-ls-ppa $(1) | pad-to 10M | \
+                       append-ls-ppfe | pad-to 15M | \
+                       append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
+                       append-kernel | pad-to 32M | \
+                       append-ubi | check-size 67108865
+endef
+TARGET_DEVICES += ls1012afrdm
+
 ifeq ($(SUBTARGET),armv8_64b)
 define Device/ls1088ardb
   DEVICE_TITLE := ls1088ardb-$(SUBTARGET)
   DEVICE_PACKAGES +=   rcw-layerscape-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb \
-                       layerscape-mc-ls1088ardb layerscape-dpl-ls1088ardb restool
+                       layerscape-mc-ls1088ardb layerscape-dpl-ls1088ardb restool \
+                       layerscape-ppa-ls1088ardb
   DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1088a-rdb
+  FILESYSTEMS := ubifs
+  UBIFS_OPTS := -m 1 -e 262016 -c 128
+  UBINIZE_OPTS := -E 5
+  BLOCKSIZE := 256KiB
+  PAGESIZE := 1
   IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
-                       append-ls-uboot $(1) | pad-to 10M | \
+                       append-ls-uboot $(1) | pad-to 4M | \
+                       append-ls-ppa $(1) | pad-to 10M | \
                        append-ls-mc $(1) | pad-to 13M | \
                        append-ls-dpl $(1) | pad-to 14M | \
                        append-ls-dpc $(1) | pad-to 15M | \
                        append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
                        append-kernel | pad-to 32M | \
-                       append-ls-rootfs-ext4 $(1) 17M | check-size 67108865
+                       append-ubi | check-size 67108865
 endef
 TARGET_DEVICES += ls1088ardb
 
 define Device/ls2088ardb
   DEVICE_TITLE := ls2088ardb-$(SUBTARGET)
   DEVICE_PACKAGES +=   rcw-layerscape-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb \
-                       layerscape-mc-ls2088ardb layerscape-dpl-ls2088ardb restool
+                       layerscape-mc-ls2088ardb layerscape-dpl-ls2088ardb restool \
+                       layerscape-ppa-ls2088ardb
   DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
   IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
-                       append-ls-uboot $(1) | pad-to 10M | \
+                       append-ls-uboot $(1) | pad-to 4M | \
+                       append-ls-ppa $(1) | pad-to 10M | \
                        append-ls-mc $(1) | pad-to 13M | \
                        append-ls-dpl $(1) | pad-to 14M | \
                        append-ls-dpc $(1) | pad-to 15M | \