use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 7b375d607569ff9814a18e5c3c713d6b11994b20..161c8cb8168fb25e4c98a6f280f57f6425ef99ab 100644 (file)
@@ -10,21 +10,25 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
-FEATURES:=spe_fpu squashfs
+FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
 
-LINUX_VERSION:=3.10.24
+KERNEL_PATCHVER:=4.4
+
+define Target/Description
+       Build images for the Freescale MPC85xx based boards.
+endef
 
 include $(INCLUDE_DIR)/target.mk
 
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))