use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index c84c0e291150bd4716b63e6c8b2c9fb8ce69607f..161c8cb8168fb25e4c98a6f280f57f6425ef99ab 100644 (file)
@@ -9,18 +9,26 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
+CPU_TYPE:=8540
+FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic p1020
 
-LINUX_VERSION:=3.7.8
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += kmod-booke-wdt
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
+
 $(eval $(call BuildTarget))