kernel: update 3.10 to 3.10.21
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index df8204dba2c36aa4863d621006876f9e8b96a8e6..2f4bcc92d18483460669daab022b37570982596a 100644 (file)
@@ -9,17 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
+CPU_TYPE:=8540
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.10.21
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-booke-wdt swconfig
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.