mpc85xx: Add subtargets Generic and P1020
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 1a744ebcc86b8f6554bf24271df2a8a02d1b0a75..88d9b9543e4d0d33ad0541972944972c73af3f8a 100644 (file)
@@ -10,14 +10,18 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk broken
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.3.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-booke-wdt
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.