mpc85xx: Add subtargets Generic and P1020
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index ef67446f937dd70ced53d61cf8fe5a67773eea88..88d9b9543e4d0d33ad0541972944972c73af3f8a 100644 (file)
@@ -9,14 +9,20 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
-FEATURES:=spe_fpu ramdisk broken
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=2.6.36.4
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef