mpc85xx: use image metadata
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 597ac9e828e7f3b5afcdf09863aa3071ebfe43ac..b181e67c0e5e126697485eb59681947a0a0b5433 100644 (file)
@@ -9,18 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
+CPU_TYPE:=8540
+FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic p1020
 
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=4.9
 
 
-include $(INCLUDE_DIR)/target.mk
+KERNELNAME:=zImage
 
 
-DEFAULT_PACKAGES += kmod-booke-wdt
+include $(INCLUDE_DIR)/target.mk
 
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))
 
 $(eval $(call BuildTarget))